Degraded Performance

Incident

Degraded Performance

Status: Closed
Start:
End:
Duration: 1 hour 36 minutes
Affected Components:
Higher Education Courseware Learning Catalytics Mastering MyLab Pearson + Pearson Interactive Labs Revel StatCrunch
Update

Amazon Web Services, AWS, is experiencing a degradation to a number of services in their US region. Customers may experience intermittent service impacts or delays across our products. We are monitoring the situation and will provide an update in the next hour. 


Update

Amazon Web Services, AWS, is continuing to experience degradation to a few services in their US region which may be causing delays across our products. We are continuing to monitor the situation. 

Resolved

Amazon Web Services, AWS, has reported all services have recovered. All degradations within our products have also been resolved. We appreciate your patience as we worked to address the issue