Pearson English Portal downtime
Maintenance
2023-09-23T09:00:04.3730000Z
Pearson English Portal downtime
Status: Closed
Start:
2023-09-23T05:00:00.0000000Z
End:
2023-09-23T09:00:04.3730000Z
Duration: 4 hours
Affected Components:
English Language Learning
MyEnglishLab (MEL)
Pearson English Connect (PEC)
Pearson English Portal (PEP)
Pearson English Portal App
Pearson Practice English (PPE) App
Update
2023-09-23T05:00:00.0000000Z
2023-09-23T05:00:00.0000000Z
We will be performing maintenance during this time. Users will not be able to access.
Resolved
2023-09-23T09:00:04.3730000Z
2023-09-23T09:00:04.3730000Z
We have concluded the maintenance event. Thanks for your patience as we completed this update.