HED Scheduled Maintenance

Maintenance

HED Scheduled Maintenance

Status: Closed
Start:
End:
Duration: 8 hours
Affected Components:
Higher Education Courseware Pearson + Revel
Update

We will be performing maintenance. During this time, access will be unavailable. 

Resolved

We have completed scheduled maintenance. Thanks for your patience.