MyEnglishLab and Pearson English Portal Maintenance
Maintenance
2023-11-25T14:00:07.8400000Z
MyEnglishLab and Pearson English Portal Maintenance
Status: Closed
Start:
2023-11-25T06:00:00.0000000Z
End:
2023-11-25T14:00:07.8400000Z
Duration: 8 hours
Affected Components:
English Language Learning
MyEnglishLab (MEL)
Pearson English Connect (PEC)
Pearson English Portal (PEP)
Pearson English Portal App
Pearson Practice English (PPE) App
Reader+ / eBook / eText
Update
2023-11-25T06:00:00.0000000Z
2023-11-25T06:00:00.0000000Z
MyEnglishLab (MEL), Pearson English Portal (PEP) is under maintenance. During this time, access will be unavailable.
Resolved
2023-11-25T14:00:07.8400000Z
2023-11-25T14:00:07.8400000Z
We have concluded the maintenance event. Thanks for your patience as we completed this update.