Degraded Performance

Incident

Degraded Performance

Status: Closed
Start:
End:
Duration: 56 minutes
Affected Components:
Higher Education Courseware Mastering MyLab
Update

Some customers report issues with course access and may receive an error message stating, 'Sorry, we couldn't open your course.' We are working to restore services and will update you in 60 minutes. 

Update

We have confirmed a technical issue that may impact your course access. Some customers may see an error message stating, 'Sorry, we couldn't open your course,' while others may be redirected. Teams are working on resolving this issue; we apologize for any inconvenience. 

Resolved

We appreciate your patience while we addressed the issue. This incident is now resolved.