Degraded Performance

Incident

Degraded Performance

Status: Closed
Start:
End:
Duration: 2 hours 32 minutes
Affected Components:
English Language Learning MyEnglishLab (MEL) Pearson English Connect (PEC) Pearson English Portal (PEP) Pearson English Portal App Pearson Practice English (PPE) App
Update

We're getting customer reports that they cannot access their products. We are working to restore services and will update you in 60 minutes. 

Update

We have confirmed a technical issue that may impact course access. Some customers may experience an error message when attempting to sign in to courses. Teams are working on resolving this issue; we apologize for any inconvenience. 

Resolved

Systems are fully operational, and we have resolved this incident. We appreciate your patience as we worked to address the issue