Versant Maintenance

Maintenance

Versant Maintenance

Status: Closed
Start:
End:
Duration: 30 minutes
Affected Components:
English Language Learning Versant
Update

Score Keeper platform maintenance is scheduled for Friday, December 8th, 2023.  

Resolved

We have concluded the maintenance event. Thanks for your patience as we completed this update.