Mastering and Pearson+ Maintenance
Maintenance
2024-02-10T14:00:12.8300000Z
Mastering and Pearson+ Maintenance
Status: Closed
Start:
2024-02-10T06:00:00.0000000Z
End:
2024-02-10T14:00:12.8300000Z
Duration: 8 hours
Affected Components:
Higher Education Courseware
Mastering
Pearson +
Update
2024-02-10T06:00:00.0000000Z
2024-02-10T06:00:00.0000000Z
Mastering will be performing maintenance; during this time, access will be unavailable. Pearson+ customers may experience a brief disruption to purchase and registration.
Resolved
2024-02-10T14:00:12.8300000Z
2024-02-10T14:00:12.8300000Z
We have concluded the maintenance event. Thanks for your patience as we completed this update.