Higher Education Maintenance

Maintenance

Higher Education Maintenance

Status: Closed
Start:
End:
Duration: 8 hours
Affected Components:
Higher Education Courseware Learning Catalytics Mastering MathXL For School MyLab Pearson + Pearson Interactive Labs Revel StatCrunch
Update

Higher Education will perform maintenance on Saturday, March 23, 2024, from 1:00 AM to 9:00 AM ET. During this time, Pearson+ will be unavailable. Additionally, content creation and content search for Mastering, My Labs, Revel and Learning Catalytics will be unavailable. 

Resolved

We have concluded the maintenance event. Thanks for your patience as we completed this update.