Higher Education Maintenance
Maintenance
2024-06-29T13:00:00.0000000Z
Higher Education Maintenance
Status: Closed
Start:
2024-06-29T05:00:00.0000000Z
End:
2024-06-29T13:00:00.0000000Z
Duration: 8 hours
Affected Components:
Higher Education Courseware
Pearson +
Revel
Update
2024-06-29T05:00:00.0000000Z
2024-06-29T05:00:00.0000000Z
During this time, access to Revel and Pearson+ will be unavailable.
Resolved
2024-06-29T13:00:00.0000000Z
2024-06-29T13:00:00.0000000Z
We have concluded the maintenance event. Thanks for your patience as we completed this update.