Pearson Login Issues

Incident

Pearson Login Issues

Status: Closed
Start:
End:
Duration: 1 hour 1 minute
Affected Components:
Higher Education Courseware English Language Learning English Benchmark Young Learners (EBYL) Learning Catalytics Mastering MyEnglishLab (MEL) Pearson English Connect (PEC) MathXL For School MyLab Pearson English Portal (PEP) Pearson English Portal App Pearson + Pearson Practice English (PPE) App Pearson Interactive Labs Revel StatCrunch Pearson Test of English (PTE) Test Hub Reader+ / eBook / eText Versant Benchmark Test International Certificate (PTE General) Level Test Readiness Test
Update

We are investigating an issue with login. As a result, customers may see a "503 server temporarily unavailable" error when attempting to access courses. We will update you in the next 60 minutes with more information.

Update

We are troubleshooting an issue preventing Pearson customers from logging in to courses. Customers may experience a "503 server temporarily unavailable" error. We apologize for the inconvenience and will update you when new information becomes available.

Resolved

Systems are fully operational, and we have resolved this incident. We appreciate your patience as we worked to address the issue