Degraded Performance

Incident

Degraded Performance

Status: Closed
Start:
End:
Duration: 30 minutes
Affected Components:
Higher Education Courseware Mastering MathXL For School MyLab Revel
Update

We're getting customer reports that users may have issues with content access and assignments. We are working to restore services and will update you in 60 minutes.

Resolved

The issue preventing content, assignments and grades from loading has been fixed. We appreciate your patience.