Degraded Performance
Incident
March 21st 2024, 11:47am GMT
Degraded Performance
Status: Closed
Start:
March 21st 2024, 11:16am GMT
End:
March 21st 2024, 11:47am GMT
Duration: 31 minutes
Affected Components:
English Language Learning
MyEnglishLab (MEL)
Pearson English Connect (PEC)
Pearson English Portal (PEP)
Pearson English Portal App
Pearson Practice English (PPE) App
Update
March 21st 2024, 11:16am GMT
March 21st 2024, 11:16am GMT
We're getting customer reports that they cannot access their MyEnglishLab and Pearson English Portal services. We are working to restore services and will update you in 60 minutes.
Resolved
March 21st 2024, 11:47am GMT
March 21st 2024, 11:47am GMT
Pearson English Portal and MyEnglishLab services remain healthy and stable, and the issue is now resolved.