Maintenance

Maintenance

Maintenance

Status: Closed
Start:
End:
Duration: 6 hours
Affected Components:
English Language Learning Test Hub Benchmark Test International Certificate (PTE General) Level Test Readiness Test
Update

We will be performing maintenance. During this time, access to Test Hub will be unavailable. 

Resolved

We have concluded the maintenance event. Thanks for your patience as we completed this update.