Higher Education Maintenance

Maintenance
October 19th 2024, 1:00pm GMT

Higher Education Maintenance

Status: Closed
Start: October 19th 2024, 5:00am GMT
End: October 19th 2024, 1:00pm GMT
Duration: 8 hours
Affected Components:
Higher Education Courseware Learning Catalytics Mastering MathXL For School MyLab StatCrunch
Update

October 19th 2024, 5:00am GMT

October 19th 2024, 5:00am GMT

Higher Education planned maintenance. During this time, access will be unavailable.

Resolved

October 19th 2024, 1:00pm GMT

October 19th 2024, 1:00pm GMT

We have concluded the maintenance event. Thanks for your patience as we completed this update.