Maintenance
Maintenance
2024-05-18T13:00:00.0000000Z
Maintenance
Status: Closed
Start:
2024-05-18T05:00:00.0000000Z
End:
2024-05-18T13:00:00.0000000Z
Duration: 8 hours
Affected Components:
Higher Education Courseware
MathXL For School
MyLab
Update
2024-05-18T05:00:00.0000000Z
2024-05-18T05:00:00.0000000Z
We will perform system maintenance on Saturday, May 18th, from 1:00 to 9:00 AM ET. During this time, access to MyLab courses will be unavailable. All Mastering courses will be operational.
Resolved
2024-05-18T13:00:00.0000000Z
2024-05-18T13:00:00.0000000Z
We have concluded the maintenance event. Thanks for your patience as we completed this update.