Degraded Performance

Maintenance

Degraded Performance

Status: Closed
Start:
End:
Duration: 4 hours 40 minutes
Affected Components:
Higher Education Courseware MathXL For School MyLab
Update

We are currently performing maintenance. During this time, access will be unavailable.

Update

We have confirmed a technical issue that may impact your XL based Higher Education course(s). Some customers may experience slowness or blank pages when navigating within their course(s). Teams are working on resolving this issue; we apologize for any inconvenience. 

Resolved

We appreciate your patience while we addressed this issue. This incident is now resolved.