Q-global Canada Monthly Maintenance

Maintenance

Q-global Canada Monthly Maintenance

Status: Closed
Start:
End:
Duration: 1 hour
Affected Components:
Clinical Assessments Q-Global
Update

Q-global will be performing monthly maintenance during this time and will be unavailable.

Resolved

Thank you for your patience as we completed this maintenance.