Q-global CA Monthly Maintenance

Maintenance

Q-global CA Monthly Maintenance

Status: Closed
Start:
End:
Duration: 1 hour
Affected Components:
Clinical Assessments Q-Global
Update

Q-global CA will perform monthly maintenance during this time and will be unavailable.

Resolved

We have concluded the maintenance event. Thanks for your patience as we completed this update.