Q-Global CA
Maintenance
2024-06-23T03:00:00.0000000Z
Q-Global CA
Status: Closed
Start:
2024-06-22T23:00:00.0000000Z
End:
2024-06-23T03:00:00.0000000Z
Duration: 4 hours
Affected Components:
Clinical Assessments
Q-Global
Update
2024-06-22T23:00:00.0000000Z
2024-06-22T23:00:00.0000000Z
Q-global CA will perform monthly maintenance during this time and will be unavailable.
Resolved
2024-06-23T03:00:00.0000000Z
2024-06-23T03:00:00.0000000Z
We have concluded the maintenance event. Thanks for your patience as we completed this update.