Pearson English Portal Maintenance

Maintenance

Pearson English Portal Maintenance

Status: Closed
Start:
End:
Duration: 3 hours
Affected Components:
English Language Learning Pearson English Portal (PEP)
Update

We will be performing system maintenance. During this time, access to Pearson English Portal will be unavailable.

Resolved

We have concluded the maintenance event. Thanks for your patience as we completed this update.