MyLab and Mastering Course Creation Issue

Incident

MyLab and Mastering Course Creation Issue

Status: Closed
Start:
End:
Duration: 1 hour 40 minutes
Affected Components:
Higher Education Courseware Mastering MathXL For School MyLab
Update

We are experiencing an issue with course creation. Courses created at this time will be queued and processed in the order they are received. We are working to restore services and will update you in 60 minutes.

Resolved

Systems are fully operational, and we have resolved this incident. We appreciate your patience as we worked to address the issue