Q-Global US Planned Maintenance
Maintenance
2024-09-24T06:00:00.0000000Z
Q-Global US Planned Maintenance
Status: Closed
Start:
2024-09-24T05:00:00.0000000Z
End:
2024-09-24T06:00:00.0000000Z
Duration: 1 hour
Affected Components:
Clinical Assessments
Q-Global
Update
2024-09-24T05:00:00.0000000Z
2024-09-24T05:00:00.0000000Z
During this time, access to Q-Global will be unavailable.
Resolved
2024-09-24T06:00:00.0000000Z
2024-09-24T06:00:00.0000000Z
Thanks for your patience as we completed this critical maintenance.