Revel Planned Maintenance
Maintenance
2024-10-19T14:00:00.0000000Z
Revel Planned Maintenance
Status: Closed
Start:
2024-10-19T02:00:00.0000000Z
End:
2024-10-19T14:00:00.0000000Z
Duration: 12 hours
Affected Components:
Higher Education Courseware
Revel
Update
2024-10-19T02:00:00.0000000Z
2024-10-19T02:00:00.0000000Z
We will perform maintenance on Friday, October 18th, 2024, from 10 PM ET to Saturday, October 19th, at 10:00 AM ET. During this time, access to Revel will be unavailable.
Resolved
2024-10-19T14:00:00.0000000Z
2024-10-19T14:00:00.0000000Z
We have concluded the maintenance event. Thanks for your patience as we completed this update.