Q-Global CDN Planned Maintenance
Maintenance
2024-09-25T02:00:00.0000000Z
Q-Global CDN Planned Maintenance
Status: Closed
Start:
2024-09-25T01:00:00.0000000Z
End:
2024-09-25T02:00:00.0000000Z
Duration: 1 hour
Affected Components:
Clinical Assessments
Q-Global
Update
2024-09-25T01:00:00.0000000Z
2024-09-25T01:00:00.0000000Z
During this time, Q-Global Canada will be unavailable.
Resolved
2024-09-25T02:00:00.0000000Z
2024-09-25T02:00:00.0000000Z
We have concluded the maintenance event. Thanks for your patience as we completed this update.