Mastering Maintenance
Maintenance
2024-10-26T13:00:00.0000000Z
Mastering Maintenance
Status: Closed
Start:
2024-10-26T05:00:00.0000000Z
End:
2024-10-26T13:00:00.0000000Z
Duration: 8 hours
Affected Components:
Higher Education Courseware
Mastering
Update
2024-10-26T05:00:00.0000000Z
2024-10-26T05:00:00.0000000Z
Access to Mastering will be intermittently unavailable on Saturday, October 26th, from 1:00 AM ET to 9:00 AM ET.
Resolved
2024-10-26T13:00:00.0000000Z
2024-10-26T13:00:00.0000000Z
We have concluded the maintenance event. Thanks for your patience as we completed this update.