Mastering Maintenance
Maintenance
2024-11-02T13:00:00.0000000Z
Mastering Maintenance
Status: Closed
Start:
2024-11-02T05:00:00.0000000Z
End:
2024-11-02T13:00:00.0000000Z
Duration: 8 hours
Affected Components:
Higher Education Courseware
Mastering
Update
2024-11-02T05:00:00.0000000Z
2024-11-02T05:00:00.0000000Z
Access to Mastering Anatomy and Physiology, Health & Nutrition, Geology, and Environmental Science courses will be unavailable during this time.
Resolved
2024-11-02T13:00:00.0000000Z
2024-11-02T13:00:00.0000000Z
Thanks for your patience as we completed the maintenance event.