Maintenance: TestHub PEIC Maintence

Maintenance

Maintenance: TestHub PEIC Maintence

Status: Closed
Start:
End:
Duration: 5 days 1 hour
Affected Components:
English Language Learning Test Hub Benchmark Test International Certificate (PTE General) Level Test Readiness Test
Update

We will perform system maintenance from 10:00 AM UTC on October 10th, 2024, to 11:00 AM UTC on October 15th, 2024. During this time, you will be unable to book PEIC tests. Services will resume gradually on Tuesday, October 15th, 2024.


We apologize for the inconvenience. 

Resolved

We have concluded the maintenance event. Thanks for your patience as we completed this update.