Degraded Performance
Incident
2024-10-15T05:44:00.0000000Z
Degraded Performance
Status: Closed
Start:
2024-10-14T15:49:00.0000000Z
End:
2024-10-15T05:44:00.0000000Z
Duration: 13 hours 55 minutes
Affected Components:
Higher Education Courseware
Mastering
MathXL For School
MyLab
Pearson +
Revel
StatCrunch
Update
2024-10-14T15:49:00.0000000Z
2024-10-14T15:49:00.0000000Z
We're getting customer reports that they cannot launch courses or navigate content. We are working to restore services and will update you in 60 minutes.
Resolved
2024-10-15T05:44:00.0000000Z
2024-10-15T05:44:00.0000000Z
We appreciate your patience while we addressed this issue. This incident is now resolved.