Maintenance: Mastering Microbiology, Genetics and Geography
Maintenance
2024-10-19T14:00:00.0000000Z
Maintenance: Mastering Microbiology, Genetics and Geography
Status: Closed
Start:
2024-10-19T02:00:00.0000000Z
End:
2024-10-19T14:00:00.0000000Z
Duration: 12 hours
Affected Components:
Higher Education Courseware
Mastering
Update
2024-10-19T02:00:00.0000000Z
2024-10-19T02:00:00.0000000Z
Access to Mastering Microbiology, Genetics, and Geography will be unavailable during this time.
Resolved
2024-10-19T14:00:00.0000000Z
2024-10-19T14:00:00.0000000Z
Thanks for your patience as we completed this maintenance event.