Maintenance
Maintenance
2024-10-19T15:00:00.0000000Z
Maintenance
Status: Closed
Start:
2024-10-19T14:00:00.0000000Z
End:
2024-10-19T15:00:00.0000000Z
Duration: 1 hour
Affected Components:
English Language Learning
Test Hub
Benchmark Test
International Certificate (PTE General)
Level Test
Readiness Test
Update
2024-10-19T14:00:00.0000000Z
2024-10-19T14:00:00.0000000Z
We will perform system maintenance from 2:00 pm to 3:00 pm UTC on 19th October 2024. During this time, Level, Benchmark, and Readiness systems will be unavailable
Resolved
2024-10-19T15:00:00.0000000Z
2024-10-19T15:00:00.0000000Z
We have concluded the maintenance event. Thanks for your patience as we completed this update.