Degraded Performance
Incident
2024-11-13T19:41:00.0000000Z
Degraded Performance
Status: Closed
Start:
2024-11-13T18:54:00.0000000Z
End:
2024-11-13T19:41:00.0000000Z
Duration: 47 minutes
Affected Components:
Clinical Assessments
Q-Global
Update
2024-11-13T18:54:00.0000000Z
2024-11-13T18:54:00.0000000Z
Some US based customers may be unable to access all of Q-global services or generate reports. We are working to restore services and will update you in 60 minutes.
Resolved
2024-11-13T19:41:00.0000000Z
2024-11-13T19:41:00.0000000Z
Systems are fully operational, and we have resolved this incident. We appreciate your patience as we worked to address the issue.