Degraded Performance
Incident
2024-11-14T11:46:00.0000000Z
Degraded Performance
Status: Closed
Start:
2024-11-14T11:18:00.0000000Z
End:
2024-11-14T11:46:00.0000000Z
Duration: 28 minutes
Affected Components:
Higher Education Courseware
English Language Learning
Mastering
MyEnglishLab (MEL)
MyLab
Pearson English Portal (PEP)
Test Hub
Benchmark Test
International Certificate (PTE General)
Level Test
Readiness Test
Update
2024-11-14T11:18:00.0000000Z
2024-11-14T11:18:00.0000000Z
We received reports from some customers that they may have received errors when attempting to login to their product(s). The issue is now resolved and we thank you for your patience while we investigated this.
Resolved
2024-11-14T11:46:00.0000000Z
2024-11-14T11:46:00.0000000Z
Systems are fully operational, and we have resolved this incident. We appreciate your patience as we worked to address the issue.