My English Lab and TestHub Maintenance
Maintenance
2024-12-07T16:00:00.0000000Z
My English Lab and TestHub Maintenance
Status: Closed
Start:
2024-12-07T08:00:00.0000000Z
End:
2024-12-07T16:00:00.0000000Z
Duration: 8 hours
Affected Components:
English Language Learning
MyEnglishLab (MEL)
Test Hub
Benchmark Test
International Certificate (PTE General)
Level Test
Readiness Test
Update
2024-12-07T08:00:00.0000000Z
2024-12-07T08:00:00.0000000Z
Due to system maintenance, MyEnglish Lab and TestHub will be unavailable.
Resolved
2024-12-07T16:00:00.0000000Z
2024-12-07T16:00:00.0000000Z
We have concluded the maintenance event. Thanks for your patience as we completed this update.