Revel Maintenance

Maintenance

Revel Maintenance

Status: Closed
Start:
End:
Duration: 12 hours
Affected Components:
Higher Education Courseware Revel
Update

We will be performing system maintenance, during this time, access to Revel will be unavailable. 

Resolved

We have concluded the maintenance event. Thanks for your patience as we completed this update.