System Maintenance: MyLab IT
Maintenance
2024-12-21T14:00:00.0000000Z
System Maintenance: MyLab IT
Status: Closed
Start:
2024-12-21T06:00:00.0000000Z
End:
2024-12-21T14:00:00.0000000Z
Duration: 8 hours
Affected Components:
Higher Education Courseware
MyLab
Update
2024-12-21T06:00:00.0000000Z
2024-12-21T06:00:00.0000000Z
During this time, access MyLab IT will be unavailable. Students will not be able to access IT SIMS and IT Grader assignments.
Resolved
2024-12-21T14:00:00.0000000Z
2024-12-21T14:00:00.0000000Z
We have concluded the maintenance event. Thanks for your patience as we completed this update.