Mastering Maintenance
Maintenance
2025-03-22T13:00:00.0000000Z
Mastering Maintenance
Status: Closed
Start:
2025-03-22T05:00:00.0000000Z
End:
2025-03-22T13:00:00.0000000Z
Duration: 8 hours
Affected Components:
Higher Education Courseware
Mastering
Update
2025-03-22T05:00:00.0000000Z
2025-03-22T05:00:00.0000000Z
During this time, Mastering courseware will be unavailable due to system maintenance.
Resolved
2025-03-22T13:00:00.0000000Z
2025-03-22T13:00:00.0000000Z
We have concluded the maintenance event. Thanks for your patience as we completed this update.