Mastering Maintenance
Maintenance
2025-04-19T14:46:00.0000000Z
Mastering Maintenance
Status: Closed
Start:
2025-04-19T05:00:00.0000000Z
End:
2025-04-19T14:46:00.0000000Z
Duration: 9 hours 46 minutes
Affected Components:
Higher Education Courseware
Mastering
Third-Party Learning Management Systems
MyLab & Mastering - Third-Party
Update
2025-04-19T05:00:00.0000000Z
2025-04-19T05:00:00.0000000Z
During this time, access to Mastering will be unavailable due to system maintenance.
Resolved
2025-04-19T14:46:00.0000000Z
2025-04-19T14:46:00.0000000Z
We have concluded the maintenance event. Thanks for your patience as we completed this update.