Revel and Learning Catalytics Higher Education Maintenance

Maintenance

Revel and Learning Catalytics Higher Education Maintenance

Status: Closed
Start:
End:
Duration: 2 days 4 hours 46 minutes
Affected Components:
Higher Education Courseware Learning Catalytics Revel
Update

During this time, access to Revel and Learning Catalytics courseware will be unavailable due to system maintenance. 

Resolved

We have concluded the maintenance event. Thanks for your patience as we completed this update.