Reader+ Maintenance
Maintenance
2024-12-20T07:00:00.0000000Z
Reader+ Maintenance
Status: Closed
Start:
2024-12-20T04:00:00.0000000Z
End:
2024-12-20T07:00:00.0000000Z
Duration: 3 hours
Affected Components:
English Language Learning
Pearson English Portal (PEP)
Reader+ / eBook / eText
Update
2024-12-20T04:00:00.0000000Z
2024-12-20T04:00:00.0000000Z
We will perform system maintenance on the Reader+ Content delivery service on Friday, December 20th, 2024, from 9:30 AM to 12:30 AM IST. During this time, customers may notice some disruption in content delivery.
Resolved
2024-12-20T07:00:00.0000000Z
2024-12-20T07:00:00.0000000Z
We have concluded the maintenance event. Thanks for your patience as we completed this update.