Test Hub Maintenance
Maintenance
2025-01-16T17:00:00.0000000Z
Test Hub Maintenance
Status: Closed
Start:
2025-01-16T07:00:00.0000000Z
End:
2025-01-16T17:00:00.0000000Z
Duration: 10 hours
Affected Components:
English Language Learning
Test Hub
Benchmark Test
International Certificate (PTE General)
Level Test
Readiness Test
Update
2025-01-16T07:00:00.0000000Z
2025-01-16T07:00:00.0000000Z
Due to maintenance, Test Hub will be unavailable.
Resolved
2025-01-16T17:00:00.0000000Z
2025-01-16T17:00:00.0000000Z
We have concluded the maintenance event. Thanks for your patience as we completed this update.