Revel Maintenance
Maintenance
2025-02-08T14:00:00.0000000Z
Revel Maintenance
Status: Closed
Start:
2025-02-08T06:00:00.0000000Z
End:
2025-02-08T14:00:00.0000000Z
Duration: 8 hours
Affected Components:
Higher Education Courseware
Revel
Update
2025-02-08T06:00:00.0000000Z
2025-02-08T06:00:00.0000000Z
During this time, access to Revel will be unavailable.
Resolved
2025-02-08T14:00:00.0000000Z
2025-02-08T14:00:00.0000000Z
We have concluded the maintenance event. Thanks for your patience as we completed this update.