Course Login Unavailable
Incident
2025-02-13T16:45:00.0000000Z
Course Login Unavailable
Status: Closed
Start:
2025-02-13T16:17:00.0000000Z
End:
2025-02-13T16:45:00.0000000Z
Duration: 28 minutes
Affected Components:
Higher Education Courseware
English Language Learning
MyEnglishLab (MEL)
Pearson English Connect (PEC)
Pearson English Portal (PEP)
Pearson +
Update
2025-02-13T16:17:00.0000000Z
2025-02-13T16:17:00.0000000Z
We are investigating an issue with course launch. As a result, customers may see an error message when attempting to login. We will update you in the next 60 minutes with more information.
Resolved
2025-02-13T16:45:00.0000000Z
2025-02-13T16:45:00.0000000Z
Systems are fully operational, and we have resolved this incident. We appreciate your patience as we worked to address the issue.