Assessment Grading Delays
Incident
2025-03-03T15:46:00.0000000Z
Assessment Grading Delays
Status: Closed
Start:
2025-03-03T14:40:00.0000000Z
End:
2025-03-03T15:46:00.0000000Z
Duration: 1 hour 6 minutes
Affected Components:
Pearson Virtual Schools
Pearson Online Classroom
Update
2025-03-03T14:40:00.0000000Z
2025-03-03T14:40:00.0000000Z
Work in Progress to restore service. We are currently experiencing an issue where students may submit assessments; however, there may be a delay with grading and previewing. We anticipate the resolution today. Thank you for your patience.
Resolved
2025-03-03T15:46:00.0000000Z
2025-03-03T15:46:00.0000000Z
Systems are fully operational, and we have resolved this incident. We appreciate your patience as we worked to address the issue.