Pearson Online Classroom Performance Improvements

Incident

Pearson Online Classroom Performance Improvements

Status: Closed
Start:
End:
Duration: 3 hours 7 minutes
Affected Components:
Pearson Virtual Schools Pearson Online Classroom
Update

We are aware of an issue preventing some users from logging in or accessing Pearson Online Classroom. Our team is actively working to resolve the problem as quickly as possible. We apologize for the inconvenience and appreciate your patience.

Update

Pearson Virtual Schools is pleased to confirm that Pearson Online Classroom is now accessible. Please continue with working in Pearson Online Classroom and with students. There may be some intermittent slowness, and we are still investigating and working towards a full solution. Thank you for your patience. 

Resolved

We’re happy to share that the Pearson Online Classroom is now restored and performing as expected. Our tech teams will continue to monitor the platform to ensure a smooth experience.

We sincerely appreciate your patience and understanding during this time and apologize for any inconvenience this may have caused.