Q-Interactive Maintenance

Maintenance

Q-Interactive Maintenance

Status: Closed
Start:
End:
Duration: 50 minutes
Affected Components:
Clinical Assessments Q-Interactive
Update

During this time, access to Central (qiactive.com) will be unavailable. Assess will be available in offline mode. 

Resolved

We have concluded the maintenance event. Thanks for your patience as we completed this update.