Degraded Performance

Incident
March 21st 2025, 5:30pm GMT

Degraded Performance

Status: Closed
Start: March 20th 2025, 1:30pm GMT
End: March 21st 2025, 5:30pm GMT
Duration: 1 day 4 hours
Affected Components:
English Language Learning MyEnglishLab (MEL)
Update

March 20th 2025, 1:30pm GMT

March 20th 2025, 1:30pm GMT

We are receiving customer reports that they cannot reset their passwords in MyEnglishLab. We are working to restore services and will update you in 60 minutes.

Update

March 20th 2025, 2:31pm GMT

March 20th 2025, 2:31pm GMT

We have confirmed a technical issue that may impact your password reset function. Teams are working on resolving this issue; we apologize for any inconvenience.

Update

March 20th 2025, 3:36pm GMT

March 20th 2025, 3:36pm GMT

We apologize for the technical issue impacting the password reset tool for your course. Technology teams are engaged and working to restore services: we appreciate your patience and will provide an update when new information becomes available.

Update

March 21st 2025, 3:02pm GMT

March 21st 2025, 3:02pm GMT

We have identified the problem with the password reset tool. Technical teams are working to implement a solution and we will update you with new information once it becomes available. We appreciate your patience.

Resolved

March 21st 2025, 5:30pm GMT

March 21st 2025, 5:30pm GMT

We appreciate your patience while we addressed this issue. This incident is now resolved.