Degraded Performance of Scheduling Activities

Incident

Degraded Performance of Scheduling Activities

Status: Closed
Start:
End:
Duration: 1 hour 27 minutes
Affected Components:
English Language Learning Pearson Test of English (PTE)
Update

We are aware that users are currently having issues with booking tests. Our team is working hard to fix these issues as quickly as possible. Thank you for your patience.

Update

We are aware that users are currently having issues with booking tests. Our team is working hard to fix these issues as quickly as possible. Thank you for your patience.

Resolved

We appreciate your patience while we addressed this issue. This incident is now resolved.