MyLab Maintenance

Maintenance

MyLab Maintenance

Status: Closed
Start:
End:
Duration: 8 hours
Affected Components:
Higher Education Courseware MyLab
Update

During this time, some customers may experience slowness or timeout errors in MyLab courses. 

Resolved

We have concluded the maintenance event. Thanks for your patience as we completed this update.