Q-Interactive Maintenance
Maintenance
2025-05-07T02:40:00.0000000Z
Q-Interactive Maintenance
Status: Closed
Start:
2025-05-07T02:00:00.0000000Z
End:
2025-05-07T02:40:00.0000000Z
Duration: 40 minutes
Affected Components:
Clinical Assessments
Q-Interactive
Update
2025-05-07T02:00:00.0000000Z
2025-05-07T02:00:00.0000000Z
During this time, access to Q-Interactive will be unavailable.
Resolved
2025-05-07T02:40:00.0000000Z
2025-05-07T02:40:00.0000000Z
Thanks for your patience as we completed this maintenance event.